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Introduction
The Infoblox IPAM plugin for vRealize Automation 8.1 integrates IP address allocation and DNS record creation
into your Cloud Assembly deployments. The Plugin also lets you create On-demand networks which can be
used for IPAM and DNS functionality, making delivery/deployment of Enterprise IT applications completely
seamless. The plugin is available on the VMware Solution Exchange and uses extensibility actions to retrieve
IP data from the Infoblox grid as well as update the grid with host records and other data for deployed virtual
machines (VM) and networks.

Prerequisites
The Following prerequisites need to be met as part of this document to use Infoblox Plugin for vRA 8:

● A VMware private cloud with vSphere suite. The environment used for this document consists of 2
ESXi 6.5 servers, with vCenter running as a virtual machine.

● A fully configured network setup in vCenter.

● Fully installed vRealize Suite Lifecycle Manager (LCM), VMware Identity Manager (IDM), and vRealize
Automation 8. It is recommended to use vRealize Easy Installer to deploy these in a few simple steps.
Refer to VMware documentation for further information.

● At least one Infoblox NIOS or vNIOS appliance that supports a minimum wapi version of 2.7.

● Infoblox grid configured for IPAM and DNS.

Workflow
The following outline describes the basic steps needed to install, configure, and use the Infoblox IPAM plugin
for vRA 8.1.

1. Configure the Infoblox grid.

2. Install the Infoblox plugin in vRA 8.

3. Create templates and customization specs in vCenter.

4. Add resources in vRA Cloud Assembly

5. Create blueprints in vRA Cloud Assembly.

6. Create a deployment from a blueprint.

7. Delete the deployment.

NIOS Setup
This section covers the steps to set up your Infoblox grid prior to installing and using the Infoblox plugin for vRA
8.1. This will cover five steps: create a DNS zone, create a network, create a network container, create a cloud
API account, and add extensible attributes.

Create DNS Zone
In order to automatically assign DNS records to new virtual machines created through vRA deployments, we
need to create an authoritative DNS zone to use for this. When we create a network, we will set this zone as
the default domain for its DHCP options.

1. Login to Infoblox Grid Manager.
2. Navigate to the Data Management -> DNS tab.

3. Click the Add dropdown, select -> Zone -> Authoritative Zone.
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4. On Step 1 of the wizard, select Add an authoritative forward-mapping zone, click Next.

5. On Step 2, enter a name for the zone, such as infobloxguide.local. Click Next.
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6. On Step 3 of the wizard, select Use this set of name servers.

7. Click the dropdown and select Grid Primary.

8. Click Select. If you have multiple members in the grid, select one from the popup window. If you have
only one member, it will be selected automatically.

9. Click Add.

10. Click Save & Close.
11. In the warning bar at the top of Grid Manger, click Restart.

12. In the Restart Grid Services window, click Restart.
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Create Network
Next, we will create a network in the Infoblox grid to use for allocating IP addresses to VMs deployed through
vRA 8.

1. Navigate to the Data Management -> IPAM tab.

2. Click the Add dropdown, select -> Network -> IPv4.

3. On Step 1 of the wizard, select Add Network -> Manually, and click Next.
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4. Enter in your desired Netmask, such as 24.

5. Click the to add a new network ID, such as 172.27.1.0.
6. Select the checkbox for Automatically Create Reverse-Mapping Zone.

7. Click Next.

8. On Step 3, click the to add an Infoblox member to manage the network.
9. If you have multiple members in the grid, select one from the popup window. If you have only one

member, it will be selected automatically.
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10. Click Next.
11. On Step 4, first set the default router for the network by clicking Override in the Routers box.

12. Under IP Address, enter the default gateway for your network.

13. Scroll down and click Override in the Domain Name box.
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The plugin will not be able to read inherited options. The Domain Name option must be
overridden and set at the network and/or range levels; otherwise, updates from the plugin will
fail.

14. Enter the domain name from the zone you created earlier, for example infobloxguide.local.
15. Click Override in the DNS Servers box.
16. Enter the IP address of your Infoblox DNS server.

17. Click Save & Close.
18. In the warning bar at the top of Grid Manger, click Restart.
19. In the Restart Grid Services window, click Restart.

Create Network Container
In this step, we will create a network container to hold networks created by vRA deployments. When we create
on demand networks through vRA Cloud Assembly, smaller blocks of IP space will be allocated from this
container for subnets.

1. From the Data Management -> IPAM tab, click the Add dropdown, select -> Network -> IPv4.
2. On Step 1 of the wizard, select Add Network Container.
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3. Click Next.
4. Enter in your desired Netmask, such as 16. Allow for a large block of address space as this will be

subnetted later.

5. Click the to add a new network ID, such as 172.30.0.0.
6. Click Save & Close.
7. Select the new Network Container and click Edit in the action menu.
8. In the edit window, open the IPv4 DHCP Options tab.
9. Using the Override buttons, set the Router, Domain Name, and DNS Server for this network block.

10. Click Save & Close.

Create Cloud API Account
Any admin account with access to the cloud API can be used for the Infoblox plugin for vRA 8, including the
default admin account. As a best practice, an account with the least required privileges should be used. This
account will need Read/Write permissions for the network objects, DNS zones, and reverse DNS zones that will
be used. It will also need permission to Read the grid DHCP properties.
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This section will detail how to set up a cloud admin account and give permissions to the cloud-api-only admin
group for use with the vRA 8 Infoblox plugin.

Create Account
1. Navigate to the Administration -> Administrators tab.

2. Click the to add a new admin user.
3. In the wizard, select Local for Authentication Type.
4. Enter a name and password for the admin account.

5. Next to Admin Group, click Select.
6. In the Admin Group Selector window, click on the cloud-api-only group.

7. Back in the Add Administrator Wizard, click Save & Close.

Set Permissions
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1. Navigate to the Administration -> Permissions tab.
2. In the Groups column, click on the cloud-api-only group.

3. Click on the dropdown and select Object Permissions.

4. Click Select Object(s).
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5. In the object filter, select IPv4 Network from the dropdown list.
6. Type the first octet of your network in the search bar.
7. Click on Search.

8. Click on the network you created earlier, or select its checkbox and click Select.
9. In the Create Object Permissions window, select Read/Write next to the resource.
10. Select Read/Write for IPv4 Host Addresses, IPv4 DHCP Ranges, and IPv4 Fixed

Addresses/Reservations.
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11. Click Save & Close.
12. Repeat steps 3 through 11 to add the same permissions for your network container. Use IPv4 Network

Container for the Type in the search filter.

13. Click on the dropdown and select Object Permissions.
14. Click Select Object(s).
15. In the object filter, select All Zones from the dropdown list.
16. Type the first part of your DNS zone name in the search bar.
17. Click on Search.

18. If needed, drag to expand the Name column to view the entire name.
19. Click on the DNS zone you created earlier, or select its checkbox and click Select.
20. In the Create Object Permissions window, select Read/Write next to the resource.
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21. Select Read/Write for Host, A Records, and PTR.

22. Click Save & Close.

23. Click on the dropdown and select Object Permissions.
24. Click Select Object(s).
25. In the object filter, select All Zones from the dropdown list.
26. Type the first octet of your network in the search bar.
27. Click on Search.
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28. Click on the reverse lookup zone you created earlier.
29. In the Create Object Permissions window, select Read/Write next to the resource.
30. Select Read/Write for Host and PTR.

31. Click Save & Close.

32. Click on the dropdown and select Global Permissions.

33. In the Permission Type dropdown, select DHCP Permissions.
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34. Select Read-Only for Grid DHCP Properties.

35. Click Save & Close.

Add Extensible Attributes for vRA Plugin
The Infoblox plugin for vRA 8 uses the following extensible attributes (EA) in the Infoblox grid to hold metadata
for resources:

● Tenant ID (string)

● CMP Type (string)

● VM ID (string)

● VM Name (string)

● VMware NIC index (integer)

● VMware resource ID (string)
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Many of these extensible attributes are added to the grid when you install the Cloud Network Automation (CNA)
licence. You will need to manually add VMware NIC index and VMware resource ID.

1. Navigate to the Administration -> Extensible Attributes tab in Grid Manager.

2. Click the to add a new extensible attribute.
3. In the wizard, enter VMware NIC index for the name.
4. Select Integer in the Type dropdown.

5. Click Save & Close.
6. Repeat the above steps using VMware resource ID for the name and String for the type.
7. Verify that all 6 extensible attributes listed above are present in your grid.
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Install Infoblox Plugin in vRA 8
The Infoblox IPAM plugin for vRA 8 is available to download on the VMware Solution Exchange,
https://marketplace.vmware.com. You will need a My VMware account to download the plugin. You can sign up
for a free account on the site.

1. On the Solution Exchange site, use the product search box to search for Infoblox.
2. In the search results locate the vRA Cloud Infoblox Plugin, newest version is 1.4.

Note: The plugin is developed and published by VMware and works with both vRA 8 and vRA Cloud.

3. Follow links to download the plugin and save it to your computer.

Add Infoblox IPAM Provider
To install the Infoblox IPAM plugin:

1. Login to vRA and open the Cloud Assembly console.
2. Navigate to the Infrastructure tab.
3. In the left menu under Connections, select Integrations.
4. Click on Add Integration.
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5. For type, select IPAM.

6. Enter a Name for the integration.
7. Click Manage IPAM Providers.

8. Click Import Provider Package.
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9. Select the Infoblox.zip file you downloaded earlier.
10. Click Open.
11. Once the file loads, click CLOSE.

12. Click in the Provider search bar.
13. Select Infoblox from the list.

14. Enter the Username for the Cloud API User you created in NIOS.
15. Enter the Cloud API User’s Password.
16. Enter the resource URL or IP address of your NIOS server.
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17. Click Validate.

18. If you get a popup regarding an untrusted certificate, click Accept to accept NIOS self-signed
certificate.

19. Wait for the validation to complete.
20. Once you see the “Credentials Validated Successfully”, click Add to finish installing the plugin.

Infoblox Deployment Guide - Infoblox IPAM Plugin for VMware vRA 8  (May 2020)
22



21. The plugin will begin running the extensibility action Infoblox_GetIPRanges.
22. To  monitor the progress, from the Infrastructure -> Integrations page, click OPEN on your new

integration.

23. View progress under Status.
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Create Resources in vCenter
Prior to configuring resources and deploying blueprints using vRA and the Infoblox plugin, you will need at least
one virtual machine template and one VM customization specification in vCenter

Create Template
Use your preferred method to create a VM template. For the template to work properly with vRA and the
Infoblox plugin, ensure:

● VMware tools are installed on the VM. OS customization will not work without this.

● Perl is installed on the VM. OS customization will not work without this.

● The network interface (NIC) for the VM is set to “Connect at Power On”.

The template used for this document uses CentOS 7 with a single NIC and open vm tools installed.

Create VM Customization Specification
Customization Specifications are XML files that allow you to customize the configuration of guest operating
systems when deploying new VMs. This guide demonstrates creating a specification for Linux VMs. Steps for
Windows VMs will differ slightly but the same settings shown here should be applied.

1. Login to the vSphere Client.
2. From the Home menu, Navigate to Policies and Profiles.

3. Click on New to create a Customization Specification.
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4. In the wizard, enter a name for the customization specification.
5. Select Linux as the Target guest OS.
6. Click NEXT.

7. On the Computer name page, ensure Use the virtual machine name is selected.
8. For Domain name, enter the domain you created earlier, for example: infobloxguide.local.
9. Click NEXT.
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10. On the Time zone page, select your Area and Location for the Time Zone. Click NEXT.
11. On the Network page, ensure “Use standard network settings for the guest operating system,

including enabling DHCP on all network interfaces” is selected.
12. Click NEXT.

13. On the DNS settings page, enter an IP address for your Primary DNS server.
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14. Under DNS Search Paths, enter the local domain you created earlier and click ADD.
15. Click NEXT.

16. On the final page, click FINISH.
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Configure Resources in vRA Cloud Assembly
This section will detail the configuration of the minimal resources needed in vRealize Automation Cloud
Assembly to deploy VMs and networks using the Infoblox plugin. The tags assigned when creating some of
these resources are particularly important as they will inform the blueprint deployment which resources to use.
The configuration items and resources needed are:

● Cloud Zone

● Project

● Image Mapping

● Network Profiles

Create Cloud Zone
According to the in-application documentation, a Cloud Zone defines the compute resources that can be used
for provisioning virtual machines. Cloud Zones also allow you to define capabilities by adding tags that will be
matched when deploying blueprints.

1. Login to vRA and open Cloud Assembly.
2. Open the Infrastructure tab.
3. Navigate to Cloud Zones under Configure.
4. Click on NEW CLOUD ZONE.

5. On the Summary tab, select your Account / region from the dropdown.
6. Enter a name for the Cloud Zone.
7. Add two Capability tags such as infoblox-demo and infoblox2. The tags can have any name you

choose. You will add these same tags to other resources in later steps to differentiate between them in
your blueprints.
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8. Click CREATE.

Create Project
According to the in-application documentation, Projects are groups that control which users can utilize which
resources.

1. Click on Projects under Configure.
2. Click NEW PROJECT.
3. On the Summary tab, enter a name for your Project.

4. Open the Users tab.
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5. Click on ADD USERS.

6. Type the first few letters of your vRA username in the search box. Select your user.
7. Use the Assign role dropdown to select Administrator.
8. Click ADD.

9. Open the Provisioning tab.
10. Click ADD CLOUD ZONE.
11. Select your Cloud zone from the list.
12. Click ADD.
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13. Add the same Tags you used for the Cloud Zone.

14. Scroll down and enter ${resource.name}-${###} for the Custom Naming Template. This will be used
for VM DNS host names, using the name we give in the blueprint concatenated with a random 3 digit
number.
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15. Click CREATE.

Create Image Mapping
Image Mappings specify VM images that will be used when deploying from blueprints.

1. Click on Image Mappings under Configure.
2. Click NEW IMAGE MAPPING.
3. Enter a name.
4. Under Configuration, search for or select your Account / Region from the dropdown.
5. Select an Image which meets the requirements discussed in the Create Resources in vCenter section

of this document.

6. Click CREATE.

Create Network Profiles
According to the in-application documentation, a Network Profile defines networks and settings used when
provisioning VMs. As a step in creating the Network Profile, we will map an IP range designated in our Infoblox
grid to be used for our VM network. We will create two network profiles, one for an existing network and one for
creating on-demand networks.

Profile for Existing Network
1. Click on Network Profiles under Configure.
2. Click NEW NETWORK PROFILE.
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3. On the Summary tab, select your Account / region.
4. Enter a Name for the profile.
5. Add a capability tag matching the first one you used for the Project and Cloud Zone, for example

infoblox-demo.

6. Open the Networks tab.
7. Click ADD NETWORK.
8. Select your Distributed Port Group.
9. Click OK.

10. Select your network and click MANAGE IP RANGES.
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11. Click NEW  IP RANGE.

12. Select External for Source.
13. Next to Provider, search for the plugin integration you added earlier.
14. Next to Address Space, select default from the dropdown.

15. Select the checkbox for the network you created earlier in your Infoblox grid.
16. Click ADD.
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17. Close the Manage IP Ranges window.
18. Click CREATE.

Profile for On-demand Networks
1. Click NEW NETWORK PROFILE.
2. On the Summary tab, select your Account / region.
3. Enter a Name for the profile.
4. Add a capability tag matching the second one you used for the Project and Cloud Zone, for example

infoblox2.
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5. Open the Network Policies tab.
6. For Isolation Policy, select Create an on-demand network from the dropdown.
7. Choose a Network domain (from your domains in vCenter).
8. For Source, select External.
9. Next to IP blocks, click ADD IP BLOCK.

10. For IPAM integration, select Infoblox.
11. For Address Space, select your network view, for example default.
12. Select the checkbox for the Network Container you created in the Infoblox grid.
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13. Click ADD.
14. For Subnet size, select a size from the dropdown. This size should create subnets that fit inside your

network container. For example if the network container is a /16, set the subnet size to /24. If the
subnet is not a smaller IP space than the network container, the deployment will fail.

15. Click CREATE.

Create Blueprints in vRA Cloud Assembly
Next, we will create two blueprints to utilize the Infoblox plugin for IPAM and DNS configuration on VMs and
allocate IP space for on-demand networks.

Create Blueprint to use Existing Network
1. In vRA Cloud Assembly, open the Design tab.
2. Select Blueprints in the left menu.
3. Click on NEW.

4. Enter a Name for the blueprint.
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5. Select your Project.

6. Click CREATE.

Add Resources
To add resources to the blueprint, drag and drop them from the resource menu onto the canvas.

1. Locate the Network and Machine resources, under vSphere.
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2. Drag and drop the Network resource onto the canvas.
3. Drag and drop the Machine resource onto the canvas. You may see a red warning message on the VM

resource; you can safely ignore this for now.

4. Click the connection point on the Network resource and drag to connect it to the VM.
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Configure Properties and Inputs
Properties and inputs for blueprint resources can be configured by adding YAML code or using Properties and
Input tabs in the blueprint editor. We will use some of each for this document.

1. Highlight the VM resource in the canvas.
2. Click on the Inputs tab on the right side of the blueprint window.

3. Click NEW.
4. For Name, enter hostname.
5. For Title, enter hostname.
6. Set Type to string.
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7. Scroll down and set a Default Value.
8. Click CREATE.

9. Click on the Code tab.
10. Click between the quotes next to image:
11. Select or type the name of the Image Mapping you created earlier.
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12. Create a new line below image.
13. Specify your Customization Specification by entering customizationSpec: <name-of-spec>. Use the

name of the Customization Specification you created in vCenter.

14. Create a new line below customizationSpec.
15. Specify the VM name by entering name: ${input.hostname}. This uses the input you created earlier

to name the VM.

16. Add a new line under - network.
17. Specify creation of a static IP by entering assignment: static.
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18. Under the Network resource, add a new line under networkType.
19. Enter constraints:
20. Under constraints, enter - tag: <tag-name>. This should be the tag you used when creating the

Network Profile for an existing network.

Your completed blueprint should look similar to the screenshot below, substituting names where appropriate.

21. Click CLOSE.

Create Blueprint for On-Demand Networks
1. Follow instructions from the previous section to create another blueprint with a different name.
2. Add two virtual machine resources, and a network resource. Connect both VMs to the network

resource.
3. Add two inputs: hostname1 and hostname2.
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4. Add a name: line to each VM. Use the appropriate input, ${input.hostname1} for VM 1 and
${input.hostname2} for VM 2.

5. Specify the image for each VM.
6. Add a customizationSpec: <name-of-spec> line for each VM. Use the name of the Customization

Specification you created in vCenter.
7. Add assignment: static to the networks section for each VM.
8. For the network resource, networkType, enter private.
9. Add a constraint tag section for the network, using the tag which matches your on-demand network

profile, for example infoblox2.

The completed blueprint should look similar to the one in the screenshots below,
substituting names where appropriate.

Canvas section of blueprint.

Infoblox Deployment Guide - Infoblox IPAM Plugin for VMware vRA 8  (May 2020)
44



Code section of blueprint.

Deploy Blueprint in vRA Cloud Assembly
Prior to deploying your blueprint, you can use the Test feature in vRA Cloud Assembly to verify that your
blueprint is valid. To test, click the TEST button in the blueprint window.

Deploying a blueprint will create the associated resources. We can monitor the deployment and see actions
taken by the Infoblox plugin in both vRA and the NIOS Grid Manager.

1. Open the blueprint you want to deploy.
2. Click the DEPLOY button.
3. In step 1 of the deployment window, enter a Name for the deployment.
4. Select or search for a Blueprint Version.
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5. Click NEXT.
6. On step 2, enter hostnames or leave the default.
7. Click DEPLOY.

You can monitor the progress of your deployment on the Deployments tab in vRA Cloud Assembly.
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View Infoblox Extensibility Actions
As part of the deployment process, the Infoblox plugin will run certain actions based on the type of request
submitted: Infoblox_AllocateIP, Infoblox_Update, and Infoblox_AllocateIPRange (for on-demand network
creation).

1. To view the details on these actions, navigate to the Extensibility tab in vRA Cloud Assembly.
2. Click on Action Runs under Activity.
3. Select All runs from the dropdown.

4. To view details on any of the actions, click on them in the table.

5. You can view details of the inputs and outputs for the action which is useful in troubleshooting.
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6. Click on the Log tab to view a sequential log of the action run.

This screenshot shows a portion of the log from the Infoblox_AllocateIP action. It shows the creation of a host
record and allocation of an IP using the next available ip function.

This screenshot shows a portion of the log from the Infoblox_AllocateIPRange action. It shows the allocation of
IP space from the network container and use of DHCP options specified for the container.

7. Click CLOSE to go back to the list of actions.
8. Click on another action such as the Infoblox_Update to view details on how it updates the Infoblox Grid

with data on the VMs created.
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9. Use the same process to deploy and view your other blueprint.

View Details in Infoblox Grid Manager
To view the DNS and IPAM data automatically added to the Infoblox grid using the vRA integration, login to Grid
Manager.

1. Navigate to the Data Management -> DNS -> Zones tab.
2. Click on the zone you created earlier to view it.

This screenshot shows the host record created for our new VM by the Infoblox_AllocateIP action.

3. To view extensible attributes added by the Infoblox_Update action, click the action menu next to
the host record.

4. Select Extensible Attributes.
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This screenshot shows the VMware specific attributes you created earlier, populated with data specific to the
newly deployed virtual machine.

5. To view IPAM data for the new VM, navigate to the Data Management -> IPAM tab.
6. Click on the network created earlier to view details.

This screenshot shows the IP which was allocated to the VM. It also contains the MAC address of the VM,
written to the grid with the Infoblox_Update action.

7. To view IPAM data for the on-demand network, navigate to the Data Management -> IPAM tab.
8. Click on your network container to open it.

9. Click on the new network, then click the to view details.
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10. Click on any of the used IPs to view details.

This screenshot shows details of the newly created network, including IP use and details for VMs.

View Deployment in vCenter
To view the new virtual machine and verify the IP and hostname were assigned, login to the vSphere client.
Navigate to Hosts and Clusters. Click on your new VM.
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This screenshot shows the IP address and hostname assigned to the VM in vCenter.

You can also login to your VMs using the web console and use network commands such as ip address show
to verify the IP address is assigned to your VM.

This screenshot shows the output of the ip address show command on a CentOS VM. Note the configured IP
address allocated from Infoblox.

Delete Deployment
The Infoblox plugin for vRA 8 includes actions to deallocate IP addresses, IP ranges, and host records when
deployments are deleted. To delete the deployment, login to vRA.

1. Navigate to Cloud Assembly, Deployments tab.
2. Click on your deployment to open it.
3. From the ACTIONS dropdown, select Delete.
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4. Click SUBMIT.
5. Monitor progress of the Delete on the Deployments tab.
6. You can view plugin actions related to deployment deletion by navigating to the Extensibility tab.

This screenshot shows the log from Infoblox_DeallocateIP action. The action has triggered deallocation of the
IP address and deletion of the host record.

To verify host records and IPAM data for the deployment have been removed from the Infoblox grid, login to
grid manager and navigate to appropriate Data tabs.

You can view this activity in Infoblox logs by navigating to Administration -> Logs -> Syslog or Audit Log.
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Limitations
● The vRA 8 Infoblox IPAM plugin v1.4 is developed and maintained by VMware. The plugin is not

officially supported by Infoblox.

● This document was tested in a vSphere 6.7 cloud environment, and not with Azure, AWS, or other
cloud providers.

● Plugin functionality is currently limited to IP address allocation, network creation, and DNS record
creation.

Additional Resources
Demo Video: https://www.youtube.com/watch?v=u35vk81J8VE&feature=youtu.be

Infoblox NIOS 8.5 Documentation: https://docs.infoblox.com/display/nios85

VMware vRealize Automation Documentation: https://docs.vmware.com/en/vRealize-Automation/index.html

Download and deploy an external IPAM provider package for use in vRealize Automation Cloud Assembly :
https://docs.vmware.com/en/vRealize-Automation/8.1/Using-and-Managing-Cloud-Assembly
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